Latest price data loss
Incident Report for Investorean
Resolved
This incident has been resolved.
Posted Jan 20, 2024 - 17:26 UTC
Identified
The issue with the missing data has been reported and confirmed. The fix is on the way.
We apologize for the inconvenience...
Posted Jan 20, 2024 - 14:47 UTC
This incident affected: Backend.